FANDOM


Desde la versión 7 del programa Acrobat Reader es posible abrir documentos PDF que contienen sonidos, vídeos y objetos 3D. Para un tentero esto significa que puede meter un modelo de Tente 3D en un pdf para que los demás puedan ver todos sus detalles, sin tener que hacer fotos desde diferentes ángulos. Este artículo indica cómo hacerlo en tres pasos con la ayuda de programas gratuitos:

  1. Conversión de LDraw a OBJ: el formato LDraw que usa Tente 3D no es el que aceptan los pdfs, que es U3D. Como no hay ningún programa que convierta directamente de LDraw a U3D hay usar un formato de intercambio, en este caso OBJ.
  2. Conversión de OBJ a U3D
  3. Creación del PDF con LaTeX: LaTeX es un sistema de composición de textos que permite generar pdfs con objetos 3D.


1. Conversión de LDraw a OBJ Editar

Instalación de LeoCad Editar

Este programa lo usaremos para abrir el fichero ldraw y exportarlo a formato obj.

Ver Tente3D: Instalación y puesta en marcha de LeoCad

Exportar al formato OBJ Editar

El modelo Tente 3D se puede crear con el mismo LeoCAD o bien se puede abrir uno ya hecho:

  • Menú File -> Open o usar el típico botón de Abrir.
  • En el panel de Abrir, cambiar el Tipo a LDraw Files (*.dat;*.ldr;*.mpd).
  • Abrir el fichero que queremos.


Una vez abierto/creado el modelo:

  • Menú File -> Export -> Wavefront
  • Seleccionar la carpeta y el nombre del archivo que queremos guardar.
  • Pulsar Guardar.

 

2. Conversión de OBJ a U3D Editar

Opción 1: Daz Studio Editar

  • Esta opción es válida para Windows y Macintosh, mientras que en Linux la versión 2 funciona con Wine. La versión actual del programa es la 3, pero este manual está hecho con la versión 2 para Windows (en principio debería ser parecido). También con la versión 1.8 se puede realizar la conversión a U3D.
  • El programa de instalación (versión 3) se puede descargar de: http://www.daz3d.com/i/software/daz_studio3/download?_m=d. La instalación no tiene nada de especial pero hay que registrarse para conseguir un número de serie que permite usar el programa durante 30 días.
  • Abrimos el programa Daz Studio.
  • Abrimos nuestro fichero OBJ a través del menú File -> Import.
  • En el panel de opciones, seleccionamos el Preset Custom. Los siguiente cambios sólo hay que indicarlos la primera vez, luego se acordará de ellos:
    • Cambiamos la escala a 1000%.
    • Marcamos la opción "Swap Y and Z Orientation".
  • Si en los paneles laterales no aparece la pestaña Surfaces, la activamos con el menú View -> Tabs -> Surfaces.
  • En la pestaña Surfaces:
    • Seleccionamos nuestro modelo en el panel superior.
    • Dentro de la pestaña Basic, en la sección Smoothing, cambiamos a 30 el valor de Angle.
    • Para todos los colores semitransparentes de nuestro modelo (sus nombres empiezan por LDraw):
      • Seleccionamos el color en el panel superior.
      • Dentro de la pestaña Basic, en la sección Common, bajamos la Opacity por debajo del 100%.
  • Vamos al menú File -> Export. Seleccionamos el Tipo "Universal 3D (*.u3d)". Escribimos un nombre para nuestro fichero U3D. Pulsamos Guardar.
  • En el siguiente panel desmarcamos las tres opciones y pulsamos Accept.
  • Al cerrar Daz Studio no es necesario guardar los cambios realizados.

Opción 2: JRViewer Editar

  • Esta opción requiere tener Java instalado en el equipo, pero funciona tanto en Windows como en Linux.Si no estás seguro de tener Java instalado:
    • Entra en la página http://java.com/es/
    • Entra en el enlace "¿Tengo Java?" que hay debajo del botón azul y sigue las instrucciones.
  • Introduce en tu navegador la dirección de JRViewer: http://www3.math.tu-berlin.de/jreality/webstart/JRViewerVR.jnlp
  • A partir de ahí Java Web Start Launcher se encarga de descargar el programa.
  • Nos aparece una advertencia de seguridad: pulsamos Ejecutar.
  • Al rato nos aparecerá el programa jReality (JRViewer es la forma abreviada de "jReality Viewer").
  • Abrimos nuestro fichero OBJ a través del menú File -> Load Content.
  • Si sólo queremos ver nuestro modelo y eliminar las cosas que ha añadido el visor:
    • Faces: desactivamos Reflection y activamos Flat Shading. (PROBLEMA: no activa el Flat Shading.)
    • Lines: desactivamos Visible.
    • Points: desactivamos Visible.
    • Sky: activamos None. (PROBLEMA:
    • Terrain: desactivamos Visible.
  • Vamos al menú File -> Export -> U3D. Seleccionamos la carpeta y el nombre para nuestro fichero U3D.
  • Hay ciertos problemas porque no cumple lo indicado:
    • Pinta el último cielo (Sky) que había antes de marcar None. Es imposible eliminar el cielo.
    • Las caras no parecen planas: no hace caso del Flat Shading.
  • Ventaja: se puede omitir el paso 3 de "Creación del PDF con LaTeX" usando el menú File -> Export -> PDF.
    • Genera un PDF en el que la ventana 3D ocupa toda la hoja.
    • No muestra la barra de navegación del entorno 3D (pero el usuario podría activarla).

 

3. Creación del PDF con LaTeX Editar

Instalación de LaTeX Editar

LaTeX no es un programa, sino un lenguaje para componer textos. Existen muchos programas y editores que permiten tener LaTeX en el ordenador.


Windows: usaremos la versión portable del programa MiKTeX.

  • Descargamos (botón Download) el programa de instalación de la página http://miktex.org/portable/about
  • Creamos la carpeta en la que se instalará, por ejemplo, C:\MiKTeX. Al ser portable, también sirve una memoria USB.
  • Ejecutamos miktex-portable-2.8.3582.exe (los números cambian con cada versión).
  • Nos pide la carpeta de instalación. Pulsamos el botón "..." y seleccionamos la carpeta "C:\MiKTeX". Pulsamos Extract.
  • Una vez terminada la extracción, el programa de instalación se cerrará automáticamente.
  • En la carpeta "C:\MiKTeX" hay un ejecutable que pondrá el icono Miktex junto al reloj.
  • Instalación del paquete movie15 (necesario para meter 3D en los pdfs)
    • Pulsamos con el botón derecho en el icono de MiKTeX y seleccionamos "MiKTeX Package Manager".
    • En la casilla Name escribimos "movie15" y pulsamos Intro.
    • Pulsamos el botón + para que descargue e instale ese paquete.
    • Una vez terminado, pulsamos Close en la ventana final y cerramos MiKTeX Package Manager.
  • Actualización de MiKTeX:
    • Pulsamos con el botón derecho en el icono de MiKTeX y seleccionamos "Update MiKTeX".
    • Pulsamos Siguiente. Se conectará a Internet para comprobar si hay actualizaciones.
    • Pulsamos Siguiente. Descargará e instalará las actualizaciones. Tardará un rato.
    • Pulsamos Siguiente. Desmarcamos la opción "Tell me more". Pulsamos Finish.


Linux (Ubuntu): el programa es TeX Live y viene en forma básica y completa (full). La completa ocupa mucho más en disco, pero tiene el paquete movie15 que nos hace falta (otra opción es instalar la básica y añadir a mano el paquete movie15).

  • (en construcción) Instalamos texlive-full.

apt-get install texlive-full texlive-lang-spanish

Plantilla LaTeX Editar

La siguiente plantilla está preparada para mostrar un modelo 3D en un cuadrado de 18 cm.

Para descargar la plantilla: http://dl.dropbox.com/u/1076721/LDraw/pdf/plantilla.tex

Se puede cambiar el nombre de la plantilla y puede guardarse en la carpeta que se desee.


Creación del PDF (Windows) Editar

Una vez instalado MiKTeX y descargada la plantilla, la creación de pdfs se reduce a estos pasos:

  • Comprobamos que el fichero u3d y la plantilla LaTeX están en la misma carpeta (carpeta de trabajo).
  • Si el icono de MiKTeX ModificarEliminarTrasladar no está junto al reloj, ejecutamos el programa que hay en C:\MiKTeX.
  • Pulsamos con el botón derecho en el icono de MiKTeX y seleccionamos TeXworks (es un editor para LaTeX).
  • En el desplegable del menú elegimos la opción "pdfLaTeX".
  • Abrimos el fichero plantilla.tex a través del menú Archivo -> Abrir o bien pulsando el típico icono de abrir.
  • Nos aparecerá una nueva ventana con una vista previa en la que es normal que no se vea bien la parte 3D. La cerramos.
  • Vamos al menú Buscar -> Reemplazar. En la casilla "Reemplazar:" escribimos "modelo.u3d", y en la casilla "Por:" escribimos el nombre de nuestro fichero U3D. Pulsamos el botón "Reemplazar todos".
  • Pulsamos el botón verde que hay junto al desplegable. La primera vez nos pedirá paquetes adicionales que necesita: pulsamos el botón Install para que los descargue e instale.
  • En la parte inferior de TeXworks aparecerán unos mensajes en la pestaña "Console output" que sólo sirven en caso de que haya algún problema en la creación del pdf. En la carpeta de trabajo aparecerá el fichero de texto plantilla.log con esa misma información.
  • Si todo ha salido bien, en la carpeta de trabajo encontraremos el fichero plantilla.pdf. Podemos cambiarle el nombre si queremos.
  • Abre el fichero PDF con el programa Acrobat Reader (versión 7 o superior) o bien otro visor de pdfs que sea capaz de ver los objetos 3D.
  • Si no vamos a hacer más pdfs, pulsamos con el botón derecho en el icono MiKTeX y seleccionamos "Exit".

Creación del PDF (Ubuntu)Editar

Orientación del modelo 3D Editar

La cámara con la que vemos la escena en 3D está determinada por los parámetros de la plantilla, por lo que cada modelo necesitará una cámara distinta. Para conseguir la orientación deseada:

  • Abrimos el pdf que hemos creado con nuestro modelo 3D.
  • Orbitamos alrededor del objeto, nos acercamos/alejamos, nos trasladamos... hasta encontrar un punto de vista que nos guste.
  • Seleccionamos "Propiedades de cámara" dentro del primer botón de la barra que aparece al poner el ratón encima del recuadro 3D. Esos parámetros son los que debemos usar en la plantilla.
  • Abre el editor de LaTeX (TeXworks en Windows, ??? en Ubuntu). En la línea que empieza por:
    • 3Daac: cambia el 36.80 por el número de la casilla "Campo de visión" (sin el símbolo de los grados).
    • 3Droll: cambia el 0.000000 por el número de la casilla "Girar" (sin los grados).
    • 3Dc2c: cambia los tres números por los valores de las casillas Cámara usando punto decimal en lugar de coma decimal.
    • 3Dcoo: cambia los tres ceros por los valores de las casillas Destino usando punto decimal en lugar de coma decimal.
    • 3Droo: es la distancia entre la cámara (Cx, Cy, Dz) y el punto de destino (Dx, Dy, Dz).
      • Se elevan al cuadrados las siguientes restas: Cx-Dx, Cy-Dy, Cz-Dz.
      • Se suman los tres valores anteriores.
      • La distancia es la raíz cuadrada de esa suma. No olvidar cambiar la coma por punto decimal en la plantilla.
  • Para cambiar el color de fondo usar (parámetro 3Dbg en la plantilla):
    • En el visor del PDF, pulsamos el último botón de la barra de la ventana 3D (opción Otro color).
    • Cambiamos el color y nos fijamos en los valores de las casillas Rojo, Verde y Azul antes de pulsar Aceptar.
    • Dividimos entre 255 esos tres valores y cambiamos la coma por punto decimal.
    • Cambiamos los tres valores 3Dbg en la plantilla por los calculados.
  • Generamos el nuevo documento PDF y comprobamos el resultado.

Visor adecuado para ver el PDF Editar

  • Para ver correctamente estos PDFs, ya sea en Windows o en Linux, necesitaremos Adobe Reader 7 o superior.
  • Las versiones anteriores y otros visores más ligeros como Foxitreader en Windows o el visor de PDF que trae Ubuntu no tienen este soporte 3D.

¡Interferencia de bloqueo de anuncios detectada!


Wikia es un sitio libre de uso que hace dinero de la publicidad. Contamos con una experiencia modificada para los visitantes que utilizan el bloqueo de anuncios

Wikia no es accesible si se han hecho aún más modificaciones. Si se quita el bloqueador de anuncios personalizado, la página cargará como se esperaba.

También en FANDOM

Wiki al azar