Fandom

Tente 3D Wiki

Tente3D: Pegatinas y serigrafías

14páginas en
el wiki
Crear una página
Discusión0 Compartir

Hacer etiquetas en formato Ldraw Editar

Introducción Editar

Vamos a ver distintos métodos para convertir las pegatinas que traen nuestros en fichas ldraw.

Software necesario Editar

Windows Editar

GNU/Linux Editar

Son los mismos programas:

  • Hay que instalar los programas wine, gimp, inkscape y blender para ello ejecutamos lo siguiente:
    • En Ubuntu: apt-get install wine gimp inkscape blender
    • En Red Hat y derivados: yum install wine gimp inkscape blender
  • Hay que descargarse las versiones Windows de MLCAD, BMP2LDRAW y LDraw Design Pad y ejecutarlas con wine.


Licencias Editar

Todos estos programas son GNU, freeware o dominio público.

Digitalización Editar

Para digitalizar la pegatina debemos tener en cuenta una serie de factores que nos evitaran mucho trabajo de limpiado a posteriori y redundará en la mayor calidad del resultado final:

  1. Utilizar un escáner o una multifunción para la captura. Por muy buen fotógrafo que seas la captura va a ser más exacta con el más sencillo de los escáneres que con la más sofisticada de las cámaras.
  2. Orientar bien la pegatina. Hay que ponerla completamente paralela al borde inferior/superior del escáner teniendo cuidado de no ponerla en alguna zona que el escáner no capture por completo y pueda cortarla. Un truco es usar una tarjeta de cartulina o un marcapáginas entre la pegatina y el borde.
  3. Si es una serigrafía es conveniente unir otra jácena larga a su parte inferior y pegar esta última al borde inferior del escáner. Si ponemos otra jácena arriba mejor.
  4. Si la pieza serigrafiada está sucia es conveniente asearla con cuidado con agua y jabón neutro. No usar nada que pueda dañar la impresión ni ser demasiado agresivo.
  5. Una vez obtenida la imagen recortarla intentando ser lo más preciso posible y guardarla en un formato sin pérdida, por ejemplo BMP.

Preparar la imagen con GIMP Editar

  1. Ir a Colores/Posterizar y poner el nivel de posterizado a 2. Si no se ven bien los colores ir subiendo el nivel uno a uno hasta que se vea correctamente.
  2. Si es una imagen en blanco y negro o monocolor ir a Colores/Desaturar.
  3. Arreglar las rectas y curvas que hayan quedado irregulares.
  4. Guardar los cambios.

Convertirla con BMP-to-LDRAW32 Editar

  • Ejecutamos el programa BMP-to-LDRAW32.
  • Pulsamos el boton Load Bitmap y elegimos el fichero BMP correspondiente.
  • Elegimos una paleta, recomendado usar la de 16 bits si no vamos a usar colores no estándar, en caso contrario hacemos caso de la recomendación de 135 colores.
  • Pulsamos siguiente.
  • Si queremos que la imagen tenga un color que podamos variar desde MLCAD:
    • Elegimos el color que queremos que varie ignorando el del fondo (ya lo eliminaremos con MLCAD en un paso posterior).
    • Seleccionamos la opción por defecto 'Replace with transparent value'
  • Si queremos que todos los colores estén fijos y queremos eliminar alguno.
    • Elegimos el color que queremos eliminar.
    • Seleccionamos la opción 'Just leave color out'
  • Pulsamos en 'Pick color' y 'Next'.
  • Seleccionamos la opción Span Over Quadrilateral...', poniendo el valor 4 16 0 0 0 0 -Y 0 X Y 0 X 0 donde:
    • Si la pegatina ocupa una jácena:
      • X = 20 x anchura en tetones.
      • Y = 24 x altura en jácena.
    • En caso de ser pegatinas que van sobre baldosas Y = 20 x altura en jácenas.
  • Pulsamos en botón 'Save as a DAT' y esperamos un ratito.

Editar

Retoque con MLCAD para eliminar el color que sobra Editar

  • Abrimos el fichero .dat resultante del paso anterior.
  • Es posible que lo veamos todo como una lámina rayada, en todo caso pinchamos en un área dónde no debería haber nada.
  • Seleccionamos todas las piezas del mismo color (opciones Editar => Seleccionar => Piezas del mismo color).
  • Pulsamos el botón suprimir.
  • Guardamos los cambios

Hacer la pegatina con Inkscape Editar

En construcción.

  • Ejecutamos el programa Inkscape.
  • Abrimos el fichero digitalizado.
  • Dibujamos encima de lo digitalizado usando las formas de inkscape (rectángulos, círculos, polígonos, etc...)
  • Borramos la capa del fichero digitalizado.
  • Guardamos el dibujo en formato SVG.

Conversión a 3D con BlenderEditar

  • Cargamos el fichero SVG en Blender
    • File -> Import -> Paths (.svg, .ps, .eps, .ai, Gimp) -> InkScape (.svg)
    • Opciones:
      • Clamp Height 1 (o bien Width 1) si la etiqueta ocupa un número entero de alturas (o tetones). - Separate curves (cada elemento sera un objeto). - Import Colors
  • Convertir de contorno a 3D:
    • Seleccionar todo (A)
    • Object -> Convert Object Type... -> Mesh
    • En una ventana Outliner podemos ver la lista de objetos.
    • Seleccionamos cada objeto y cambiamos su nombre (casilla "ME:" en panel Editing (F9).
  • Editamos los objetos para eliminar vértices extra o defectos creados por la conversión
  • Convertir triángulos a cuadriláteros: modo Edit, Alt J.
  • Seleccionamos los objetos con el mismo color y los unimos: Object -> Join Objects...
  • Cambiamos la escala:
    • S 24 (si la opción era Clamp Height 1 y la pegatina ocupa una altura de Tente)
    • S 20 (si la opción era Clamp Width 1 y la pegatina ocupa un tetón de ancho)
    • Control A -> Scale and Rotation to ObData (para fijar la nueva escala)
  • Guardamos la pieza: File -> Export -> LDraw.

Últimos retoquesEditar

Abrimos fichero DAT con editor de texto:**Eliminar el bloque "0 FILE Scene".

    • Quitar FILE en las líneas que encabezan los diferentes objetos.
    • Poner al principio las típicas líneas del nombre, Name y Author.
  • Abrimos la pieza con MLCad:
    • Eliminación de contornos:
      • Seleccionar una fila de tipo Line.
        • Edición -> Seleccionar -> Mismo tipo.
        • Borrar.
        • Lo mismo con las de tipo Optional-Line.
    • Seleccionar filas (triángulos, cuadriláteros) y asignarles su color.

Hacer la pegatina con Blender directamente Editar

En construcción.

  • Utilizar la vista de trabajo ??? (tecla ?? del teclado numérico).
  • Cargar la imagen escaneada para usarla como referencia (colocar y escalar).
  • Creación de figuras:
  1. Añadiendo una primitiva de Blender y luego modificando su geometría.
  2. Añadiendo una curva Bezier. Al final hay que convertirla a formato Mesh.
  • Unir todas las caras que vayan a tener el mismo color en un único objeto.
  • Asignar colores:
    • Importar LDraw Colors (carga los colores oficiales en la lista de Materiales).
    • Asignar a cada objeto 3D uno de esos materiales.
  • Unir todos los objetos 3D en uno y exportarlo en formato LDraw.
  • Abrir en MLCad: eliminar contornos innecesarios y cambiar los colores por los que corresponda.

Últimos retoques con LDraw DesignPad Editar

  • Abrimos el fichero DAT con LDDesignPad.
  • Lo seleccionamos todo: Edit => Select All
  • Redondeamos los valores sin que se pierda información: Edit => Autoround selection.
  • Sustituimos las primeras líneas que empiezan por cero por las siguientes:
0 Etiqueta Nombre de la etiqueta
0 Name: nombrefichero.dat
0 Author: tu nombre o nick
  • Guardamos los cambios.
  • Movemos el fichero .DAT a la subcarpeta 'models' de tu carpeta 'tente'.
  • Ejecutamos MLCad y seleccionamos Fichero => Actualizar piezas.

Imprimiendo pegatinas de Tente 3D para tente real Editar

En construcción.

¡Interferencia de bloqueo de anuncios detectada!


Wikia es un sitio libre de uso que hace dinero de la publicidad. Contamos con una experiencia modificada para los visitantes que utilizan el bloqueo de anuncios

Wikia no es accesible si se han hecho aún más modificaciones. Si se quita el bloqueador de anuncios personalizado, la página cargará como se esperaba.

También en Fandom

Wiki al azar